Degraded performance due to Cloudflare network issues

Incident Report for Apex Infosys India

Resolved

This incident has been resolved.
Posted Nov 19, 2025 - 00:19 IST

Monitoring

Cloudflare has implemented a fix for the incident affecting its global network and support services. They have stated that they “believe the incident is now resolved” and are continuing to monitor for any residual errors.

Services are now mostly accessible. We continue monitoring.
Posted Nov 18, 2025 - 22:03 IST

Investigating

We are currently experiencing intermittent errors and degraded performance across our API and Cloud Platform due to an ongoing Cloudflare incident affecting their global network. Cloudflare has confirmed an internal service degradation impacting several of their application services, which we rely on for secure access, API routing, and traffic delivery.

Between approximately 11:48 UTC and 13:35 UTC on 18 Nov 2025, Cloudflare identified the issue and began rolling out fixes. They report that some services have already begun to recover, with error rates trending back toward normal, although remediation efforts are still in progress on their end.

Cloudflare is continuing to implement fixes and reports partial recovery. Our platform is currently stable, but we are monitoring it closely and will update this page if we observe any further impact.
Posted Nov 18, 2025 - 20:51 IST
This incident affected: API and Content (Website, Data Portal, Forums).